Contents

1 Introduction 1

2 Overview of CalDose ver. 2.10 Beta 1
   2.1 Changes from CalDose ver. 1.x 1
   2.2 The CalDose database 1
       2.2.1 Measurement status 1
       2.2.2 Filters 2
       2.2.3 Reports 2

3 Validation 2

4 Feedback 2
   4.1 Contact information 3

5 Disclaimer 3

6 Installation 3
   6.1 System requirements 3
   6.2 Installation and un-installation 3

7 Getting started (administrator level) 4
   7.1 Installation of calorimeters 4
       7.1.1 Possible error message using ver. 1.x calorimeter files 4
       7.1.2 Ver. 2.x Calorimeter files 4
       7.1.3 Installation of recalibrated calorimeters 5
   7.2 Running CalDose for the First Time 5
   7.3 Setting up the Database 5
       7.3.1 Selecting database file 5
       7.3.2 Specify facility parameters 5
       7.4 User information 6
       7.5 Location of files 6
       7.6 Backup 6
       7.6.1 External backup 6
       7.7 Access rights 6
       7.8 Measurement parameter setup 6
       7.9 Table layout (table preferences) 6

8 Performing measurements (user level) 7
   8.1 Starting a new measurement 7
   8.2 Optional information 8
   8.3 Calorimeter resistances 8
   8.4 Notes 8
   8.5 Deleting measurements 8

9 Viewing measurements 8
   9.1 Selecting measurements 8
   9.2 Sorting the table 8
   9.3 Filtering the database 8
   9.3.1 Standard filters 8
9.3.2 Custom filters 9
9.4 Printing reports 9
9.5 Exporting data 9
9.6 Plotting data 9

10 Start using CalDose in a facility (administrator level) 10

11 Examples 11
11.1 Can I do the same as the Graphs tool using Excel? (Export data). 11
11.2 I suspect that one of my calorimeters is drifting – how can I investigate that? (Filter tool) 11
11.3 The calorimeters have been re-calibrated – how do I ensure that the new calibration constants are used? (Table preferences) 11

12 Error messages 13

13 Figures 14
Risø CalDose

This document refers to CalDose v2.10 Beta published December 2005.

Section 1 to 7 and 10 to 12 of the user manual is addressing the administrators of CalDose, while section 8 and 9 describes the basic use of CalDose.

Read section 1-7 before you start the installation of CalDose.

1 Introduction

The Risø CalDose software is used to calculate the absorbed dose in Risø calorimeters based on resistance measurements before and after irradiation. This User Manual describes how to setup and use CalDose.

CalDose v.2.10 Beta is a beta-version. It is fully functional, except for the help-function, but we call it a beta-version because it is the first time it is used outside Risø High Dose Reference Laboratory. We hope to get feedback from the users of CalDose, and we will probably make changes to CalDose based on this feedback before the final release.

2 Overview of CalDose ver. 2.10 Beta

2.1 Changes from CalDose ver. 1.x

CalDose ver. 2.x is a complete rewritten version of CalDose – not only is CalDose now a window based application but the way data are stored and displayed is also different. The most important change is the use of a database. While data were stored in a “log-file” style in CalDose 1.x, the new version of the program uses an internal database for data storage.

2.2 The CalDose database

The database contains information about all the measurements, i.e. resistance values and measured dose, but the database also contain information about the calorimeter calibration constants used in each measurement.

2.2.1 Measurement status

The database also keeps a record of the “status” of each measurement. A measurement has one of four possible states:

- **Scheduled**: This is a measurement, which is about to begin. The operator has specified the calorimeter to be used together with the set dose.

- **In progress**: The start resistance (i.e. the start temperature) has been measured and the calorimeter is now on its way to be irradiated.

- **Complete**: The end resistance (i.e. the end temperature) has been measured and the absorbed dose has been calculated.
• **Deleted.** The user has decided to discard the measurement. A deleted measurement is still present in the database, but will usually not be displayed and the dose does not enter in the accumulated dose of the calorimeter.

Notes can be added to each measurement. Warnings (e.g. if a dose measurement deviates too much from the expected dose) are automatically added to the notes.

It is possible to run several different calorimeters at a time, and to schedule the same calorimeter several times (e.g. for fractionated irradiation).

### 2.2.2 Filters

Although all measurements are stored within the database it is only relevant to review a small portion of the database, e.g. the most recent measurements. “Filters” are used to display the relevant data. CalDose provides some standard filters (e.g. deleted measurements or measurements that are scheduled or “in progress”), but the user can also make custom filters.

### 2.2.3 Reports

The measurements from the database, can be exported either to an ASCII file, which can be read by e.g. Excel or to an HTML report.

### 3 Validation

We have validated CalDose ver. 2.x in accordance with the FDA guidelines (Title 21 CFR §820). The documents describing the software development are distributed together with CalDose, but are also available on request from Risø High Dose Reference Laboratory.

When CalDose ver. 2.10 is used outside Risø High Dose Reference Laboratory it is the users own responsibility to claim that the software is validated, since the software is then used in a different environment than ours, but also because different users can have different requirements to the documentation needed to claim that CalDose ver. 2.10 is validated.

A starting point for the user’s validation of the software can be an evaluation of the Acceptance Test and the supplied documentation, in particular the Validation Review Report.

Although this User Manual will guide you through the use of CalDose, carrying out the Acceptance Test will allow you to be even more familiar with the way CalDose works.

### 4 Feedback

We will like to hear your opinion about the new version of CalDose. What do you think about the layout of the screen? Is the use of the database an advantage or does it make it more difficult to document the measurements? Are the standard filters sufficient? Which report type do you use the most? Are the layouts of the reports adequate? etc. …

Since it is the first time we have taken the aspect of validation into the program development, we are especially interested to know you opinion about the supplied
validation documentation. Has it been useful and sufficient for your validation of the software?

If you will report an error in the software, please make an effort to describe what you did before the error occurred. It will be helpful if you can send a copy of the screen together with the log file (“log.txt” resident in the directory where CalDose is installed).

4.1 Contact information

Send your comments to:

Risø High Dose Reference Laboratory
Risø National Laboratory
Building NUK-201
P.O. Box 49
DK 4000 Roskilde Denmark

http://www.risoe.dk/nuk/HDRL.htm

E-mail: jakob.helt-hansen@risoe.dk or arne.miller@risoe.dk

5 Disclaimer

By using CalDose you accept that Risø National Laboratory – or any person or institution involved in the development of CalDose – cannot be held responsible for any damage – direct or indirect – the use CalDose may cause.

6 Installation

6.1 System requirements

A screen resolution of 1024 x 768 is recommended.

A web-browser, e.g. Microsoft Internet Explorer, has to be installed to enable report printout.

6.2 Installation and un-installation

Run the file “setup.exe” to install CalDose. CalDose is made with LabView from National Instruments, and a free LabView run-time engine is installed automatically. Calorimeter files are distributed separately.

To un-install CalDose run “setup.exe” again and follow the instructions.
7 Getting started (administrator level)

7.1 Installation of calorimeters

Calorimeter files have to be installed before CalDose can work. The calorimeter files contain calibration data for each calorimeter and are supplied by Risø High Dose Reference Laboratory together with the calorimeters. Calorimeter files used in CalDose ver. 1.x can be used by the new version of CalDose. The calorimeter files have the extension “C1”, “C2”, … or “CAL”.

We recommend that the calorimeter files are placed in the directory called “calorimeters” located in the directory where CalDose is installed (typically in “Program files\CalDose”. If you prefer to have the calorimeter files located at another place, e.g. on a central server, this can be specified in the Options dialog located in the “tools” menu (see section 7.5). It is also possible to place the database on a central server, so several CalDose programs can access the same database.

If you use an old version of CalDose you can either copy the existing calorimeter files to the new location or download a set of calorimeter files from the CalDose web-site (see 7.1.2). These files are identical to all previous calorimeter files but they have been converted to the “CAL” format.

7.1.1 Possible error message using ver. 1.x calorimeter files

The old ver. 1.x calorimeter files (extension “C1”, “C2”, …) can generate error messages during start-up because some of the files contain preliminary thermistor data. The preliminary data does not affect calorimeters in use, and CalDose can be used regardless of the errors. However, we recommend that no errors should be displayed during start-up. If error messages are displayed you can either contact Risø High Dose Reference Laboratory, and we will remove the obsolete data from your calorimeter files, or use the ver. 2.x calorimeter files, see next paragraph.

7.1.2 Ver. 2.x Calorimeter files

Calorimeter files in the new format (*.CAL) for existing calorimeters are available on the web-page: [http://www.risoe.dk/nuk/caldose/caldose.htm](http://www.risoe.dk/nuk/caldose/caldose.htm)

These calorimeter files contain the latest calibration constants for the Risø calorimeters.

The “CAL” calorimeter files are distributed in a zip-file. Un-zip the file to the directory where you have decided to place the calorimeter files (e.g. in the directory “calorimeters” located in the directory where CalDose is installed).

The name of the individual calorimeter file, e.g. “1137-1180.CAL”, indicates the range of calorimeter numbers included in the file. You can shorten the CalDose start-up time by deleting the calorimeter files that you do not use. You can verify the calorimeter constants in the “CAL” file are the same as the ones in the previous calorimeter files by selecting “Calorimeters” in the Tools menu in CalDose.

When the “CAL” calorimeter files are used no errors should be displayed during start-up.
7.1.3 Installation of recalibrated calorimeters
When a calorimeter has been recalibrated the file with the calibration constants shall be placed in the directory containing the calorimeter files (specified in the Options dialog, see section 7.5).

CalDose will show a warning if more than one calorimeter has the same number, and the old calorimeter file must therefore be deleted.

The old calorimeter files can contain several calorimeters, and the other calorimeters in the file will have to be included in the new calorimeter file. Risø High Dose Laboratory will help you to keep the calorimeter files up-to-date.

CalDose should not be used if warnings regarding the calorimeters\(^1\) are shown during startup.

7.2 Running CalDose for the First Time
If you get an error message (5009) the first time you run CalDose it is because the configuration file is missing, but this file will then be generated automatically. The configuration file (config.cfg) contains information about the way you setup CalDose.

If you subsequent get an error message during start-up, something is wrong. The new CalDose will detect duplicate calorimeters even though they are equal. If you get error messages during startup, please contact Risø High Dose Reference Laboratory.

7.3 Setting up the Database
The Database management dialog is used to specify the location of the database file, and to supply information about the irradiation facility (see Figure 1, section 13 on page 14).

The first time you run CalDose the Database management dialog will open automatically. Later it can be found by selecting “Database” in the File menu.

7.3.1 Selecting database file
By selecting the folder-icon in the upper-right part of the dialog, you can specify the database file using a file browser (press Save to accept). The first time you use CalDose an empty database file is selected by default. You can also create a new empty database file by writing the name of the new database in the “File name” box in the file browser and press Save to accept.

7.3.2 Specify facility parameters
Below the path to the database file, there is a box called User site info tables. You can select either “Accelerator”, “Digital voltmeters” and “Operators” by dragging the small triangle.

\(^1\) Error: 5000, 5001, 5002, 5008, 5012, 5013, 5017, 5018.
Next to the box are two check boxes marked “mandatory” and “allow undefined values”. These boxes refer to the information the operator specifies when a new measurement is started. If “mandatory” is chosen you must specify that information e.g. the operator. If “allow undefined values” is enabled you will be able to specify values other than that specified in the Database management dialog – you will e.g. be able to specify another digital voltmeter than those specified in the list below.

Select “Accelerator”; press “Add” and identify the accelerator(s) of the irradiation facility. Select “Digital voltmeters”; press “Add” and specify the digital voltmeters used. Finally select “Operators” and identify the operators. Remember to set the “mandatory” and “allow undefined values” if needed.

Leave the dialog by pressing OK.

7.4 User information
In the Tools menu select Options. The Options dialog consists of four tab-pages: User information, File locations, Customization and Backup (see Figure 2).

On the “User information page” you can specify the name etc. of the irradiation facility. This information is printed on the reports generated by CalDose.

7.5 Location of files
You can specify the location of files needed and generated by CalDose on the “File locations” page in the Options dialog.

You select the type of file, e.g. Calorimeters, and press Modify. Use the file browser to locate the new directory and select it by pressing “Select current dir.”

If you want to place the calorimeter files, e.g. on a central server, you must change the path to the calorimeter directory here.

7.6 Backup
The “backup” directory specified on the “File locations” page in the Options dialog is the directory where CalDose can place a copy of the current database, i.e. the measurements, and filters at a time interval specified on the Backup tab-page.

7.6.1 External backup
The backup performed by CalDose is not secure. It will overwrite any existing backup file and will not issue a warning if the backup fails. We strongly recommend that an external backup is used to backup the database file.

7.7 Access rights
On the Customization tab-page of the Options dialog the administrator can choose to lock the access to the database dialog and to the Measurement setup dialog described below.

Leave the Options dialog by pressing OK.

7.8 Measurement parameter setup
Select Measurement setup in the Measurement dialog. In this dialog you can specify measurement parameters – mainly warning levels (see Figure 3).

7.9 Table layout (table preferences)
The measurements are presented in the main table. The user can specify what information the table shall display by selecting “Table Preferences” in the View menu (see Figure 4).

To the left of the Table preferences dialog is a list of available information and to the right is the list of information displayed in the table. Select an item in the table to the left and press “Add>>” to copy the item to the table items to the right. A selected item in the table to the left can be moved up and down with the Up and Down buttons.

It is up to the user to decide what information to display in the table, but the following could be a starting point:

- Calorimeter (the calorimeter number)
- Date
- DVM (digital voltmeter)
- Operator
- Time Start
- R start (start resistance)
- T (°C) start (start temperature)
- R end (end resistance)
- T (°C) end (end temperature)
- Meas. dose (measured dose)
- Set dose (target dose)
- % Dev. (deviation between measured and target dose)
- ID (unique database ID)

Press OK to leave the dialog.

By clicking with the mouse on the delimiter between the columns the width of the columns in the table can be set to match the length of the headline or the content of the column. See also section 9.2, Sorting the table, for important information about the display of measurements.

8 Performing measurements (user level)

8.1 Starting a new measurement
To start, or actually to “schedule”, a measurement press Ctrl+m (or press the New button). Pick the calorimeter from the pull-down list or simply write the calorimeter number in the box (see Figure 5).

CalDose will only display the available calorimeters. If a calorimeter number is not displayed and you know it should be there, please contact Risø High Dose Reference Laboratory.

CalDose will assign a letter to the calorimeter number depending on the calorimeter type: “p” for polystyrene, “g” for graphite and “w” for water.

Type in the rest of the information in the Start measurement dialog. You can jump between the boxes using “Tab” and select from the pull-down menus using the up- and down arrow-keys.
Depending on the settings of “mandatory” and “allow undefined values” in the Database management dialog (section 7.3.2), you will be able to leave a box blank, or write a value different from those listed in the pull-down lists.

Leave the dialog by pressing OK.

8.2 Optional information
You can supply extra information about the measurement in the boxes Customer, Lot ID, Serial No. and Description left of the table.

8.3 Calorimeter resistances
The measured calorimeter resistance values are entered in the “R start” and “R end” boxes. You can quickly go to these boxes by pressing F5 or F6.

8.4 Notes
You can add a note to the measurement by pressing the “Add note” button. The notes are listed in the box in the lower left corner of the screen. Warnings generated by CalDose will automatically be listed as a note.

8.5 Deleting measurements
If a wrong resistance is entered or the measurement is invalid for some other reason, the measurement can be deleted by selecting Delete in the Measurement menu or by pressing the Delete button.

A deleted measurement can be restored by selecting Restore in the Measurement menu or by pressing the Restore/Delete button again.

9 Viewing measurements

9.1 Selecting measurements
After a measurement is scheduled it will show up in the table, and it will remain there until the table is filtered (see below).

You can select a measurement by clicking with the mouse. Several measurements can be selected by holding down the shift or control key.

9.2 Sorting the table
Using the Table preferences, see section 7.9, the user can control the information displayed by the table.

The measurements in the table can be sorted by clicking the headline of a column (which turns red). Clicking again will change the sorting order (e.g. from descending to ascending).

We recommend sorting the table by either by Calorimeter number or database ID. If the table is sorted by database ID old measurements will not change their position in the table when a new measurement is introduced.

9.3 Filtering the database
All measurements are added to the database, but table should only display the relevant part of the information available in the database. A so-called “filter” is used to extract the relevant information from the database.

9.3.1 Standard filters
CalDose has a list of standard filters to extract information from the database.
“Scheduled & in progress”: This filter will only displays calorimeters, which have not been finalized. Use this filter to clear the table. The hot-key F12 (Wipe Table) will clear the table.

“Scheduled”: Shows the scheduled calorimeters.

“In progress”: Shows the calorimeters where the start calorimeter resistance has been entered.

“Last 24h”: Shows the measurements made in the last 24 hours.

“All”: Shows all the measurements in the database.

“Deleted”: Shows the deleted measurements.

If you can think of a filter type that suits you needs better, let us know.

9.3.2 Custom filters
The user can make a custom designed filter, using the Custom Filter in the View menu. After the name of the filter has been specified, a criterion is defined. A criterion could for example be, that the calorimeter number should be between 1500 and 1510, or the measurement date shall be a given date, or the start temperature should be below 15°C. The criteria can be combined by AND or OR.

The Acceptance Test (test: Custom Filter and Edit Custom Filter) gives an example of the use of custom filters.

9.4 Printing reports
“Report” in the File menu or Ctrl+p will bring up the Print dialog. You can choose between two report layouts:

Table: Prints the table as it is shown.
Details: Prints a more detailed report with a clear layout.

It is possible to print only selected measurements from the table.

The report will open as a HTML file in a web-browser and can be printed from here. The report can also be saved as a HTML file.

9.5 Exporting data
The data in the table can be exported to an ASCII file using the Export option in the File menu or Ctrl+s. If Tab is selected as separator the exported file can be read directly by e.g. Excel.

9.6 Plotting data
The graphs tool in the Tools menu can be used to evaluate trends in the measurements. To see the deviation from the set dose over time select all the measurements in the database using the “All” filter. Then select Graphs in the Tools menu. The slider underneath the graph can be used to navigate through the measurements. The magnifier icon above the graph can be used to display all or a segment of the measurements. If the cross icon is active it is possible to display the data for a specific measurement by selecting it in the graph.
10 Start using CalDose in a facility (administrator level)

Use some time to try the different possibilities in CalDose. It is also a good idea to go through the Acceptance Test supplied with CalDose.

Before CalDose is used in a facility you should either delete all the measurements you have made during testing, or even better, start a new database (see section 7.3.1, Selecting database file).
11 Examples

This section will go through some examples of the use of CalDose. Hopefully the solutions can give you an idea how to use CalDose efficiently.

11.1 Can I do the same as the Graphs tool using Excel? (Export data).

If you prefer to use Excel to draw graphs or for data analysis it is easy to export the data from the table to Excel. For example, if you want to show the deviation from the set dose for all the measurements in the database do the following:

- Select the “All” filter to show all measurements.
- Make sure that the table is sorted either by time or database ID. (Press the appropriate headline).
- Select Export in the File menu.
- Select Tab as delimiter.
- Enable “Include headers”.
- Save the file (it is saved with the extension txt).
- In Excel select Open in the File menu (ctrl+O).
- Select “Text files” in the “Files of type” box.
- Navigate to the file and select it.
- Press “Finish” in the Text Import Wizard dialog.
- The data from the CalDose table is now imported to Excel.

11.2 I suspect that one of my calorimeters is drifting – how can I investigate that? (Filter tool)

Let's assume at you suspect calorimeter number 999 to drift, but you can not identify the drift among all the other calorimeters when you use the graph tool.

You can make custom filter to pick out calorimeter 999.

- In the View menu select New filter, in the Custom Filter item. In the New Filter dialog, write “Calorimeter 999.flt” and press Save.
- Press New to enter a criterion.
- In the Field box select Calorimeter.
- In the Criteria box select EQUAL TO.
- Replace 0 by 999 in the box below.
- Press Save. Verify that the Instruction say: ‘Calorimeter’ EQUAL TO 999.000000
- Press Save.
- Make sure that the filter “Calorimeter 999” is selected.
- Select Graphs in the Tools menu.
- The graph will now show the deviation from set dose for calorimeter 999 only.

11.3 The calorimeters have been re-calibrated – how do I ensure that the new calibration constants are used? (Table preferences)

There are two possibilities to view the calibration constants for the calorimeters. The fastest way to evaluate the constants is to select “Calorimeters” in the Tools menu.
Select Calorimeter constants in the box below the table. You can export the data to a text file.

You can also see the calibration constants by selecting Table preferences in the View menu. Select k, K1 and K2 from the Select columns list and add them (one at a time) to the New columns list. The constants will now be shown in the Table.
12 Error messages
Below is a list of the error messages generated by CalDose. Other error messages might be displayed, but these are generated by the LabView runtime-engine.

5000: Error in calibration checksum
5001: Unable to determine calorimeter type.
5002: Unable to read calorimeter file. File might have been corrupted.
5003: Unable to read database. File might have been corrupted.
5004: Unable to read configuration file. File might have been corrupted.
5005: Unable to read filter file. File might have been corrupted.
5006: Unable to write log.
5007: Filter not found.
5008: Some calorimeters where not loaded. Please see log file for details.
5009: Unable to read configuration file. File might have been corrupted. Default configuration used instead.
5010: No matches found.
5011: Database contains multiple entries.
5012: Calorimeter not found.
5013: Multiple calorimeters have the same ID. To avoid this message at start-up, please make sure that the calorimeter directory does not contain multiple data for the same calorimeter.
5014: No calorimeters were loaded. Please verify that the calorimeter files path in the configuration file points to a location containing calorimeter files.
5017: Could not read calibration date from header.
5018: Could not read calibration temperature range from header.
5019: Database could not be read. Please specify the location of an existing CalDose database file or create a new file.
5020: Start temperature is too low. Please see "measurement setup" for calculation limits.
5021: Calculated end temperature is too high. Please see "measurement setup" for calculation limits.
5022: Calculated temperature increase is too high. Please see "measurement setup" for calculation limits.
5023: Calculated deviation between measured and set dose is too high. Please see "measurement setup" for calculation limits.
5024: Exposure time was too long. Please see "measurement setup" for calculation limits.
5025: Measurement not found in data file.
5026: Measurement ID is not unique in data file.
5027: Calorimeter not found.
5028: One or more calorimeters have the same ID.
5029: One or more calculation output limits were exceeded. Please see "measurement setup" for details.
5030: Calorimeter type unknown.
5031: Cannot determine dose calculation parameter Tα. Default value (0.05) used instead.
5032: No matches found in DB.
5033: One or more measurements have the same ID.
5034: Database does not contain a measurement with that ID.
5035: The accumulated dose of a calorimeter cannot be negative. The updated dose was set to 0.
5036: Update failed.
5040: Internet Explorer not found. A version of Internet Explorer needs to be installed in order to print reports from CalDose.
5050: Measurement with that ID not displayed in table. Row not updated.
5051: Measurement with that ID is already displayed in the table. Row not added.
6000: Primary key violation. Entry with the specified value already exists.
6001: Foreign key violation. Another table field refers to this value.
13 Figures

Figure 1 Database management dialog – configuration of database.

Figure 2 Options dialog – showing file locations.
Figure 3 Measurement setup dialog.

Figure 4 Table preferences dialog.

Figure 5 New measurement dialog.
Figure 6 CalDose main window.